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Creating drop-down lists (1)

«Drop-down lists can be created in Excel to assist with data entry and 

to reduce input errors and typing mistakes».



Creating drop-down lists (2)

Steps for creating a simple drop-down list:

Type the entries you want to see in the drop-down list.

Select and name the range of cells containing the entries for the list (entering

a name into the “Name Box”).

From the “Data Tab”, click the “Data Validation” command.

Select “List” from the “Allow” menu.

In the “Source” field, enter “=” followed by the named range.

“drop-

down 

list”



Creating drop-down lists (3)

Steps for creating dependent drop-down lists:

By creating a dependent drop-down lists, the entry in one is dependent upon

the selection made in another.

The first step in creating the multiple drop down lists is to name each range of

cells containing the entries for each list - This is vital as it will establish the

relationship between the lists.

For this to work, the name given to a range will need to match the wording

of the item from the previous list.



Creating drop-down lists (4)

Steps for creating dependent drop-down lists:

The first list is created normally, the other dependent lists will use the

“INDIRECT” function to reference the previous list entry - This function

converts the text (selected item) to a reference (named range).

Use the steps previously described to create the first list.

To create the dependent lists:

- From the “Data Tab”, click the “Data Validation” command.

- Select “List” from the “Allow” menu.

- In the “Source” field, enter =INDIRECT(A2), where A2 is the first cell of the

previous list.



Introduction to scatterplots (1)

A scatterplot is an excellent way to visually display the relationship

(correlation) between two variables.

In a scatter graph, both horizontal and vertical axes are value axes that plot

numeric data.

Each point represents an individual’s data on the two variables.

The tighter the data points fall along a straight line, the higher the correlation

is.

For scatterplots, 

it does not 

matter which 

variable 

goes on each 

axis (this is 

NOT true for 

other 

types of charts)

Students



In a scatterplot a “trendline” (also called “Line of Best Fit”) can be drawn.

It is drawn using statistical techniques (e.g. Least Square Regression) with

the scope to have the line as close as possible to all points, and as many

points above the line as below.

Overall, there exist three types of correlation.

- Positive Correlation: as the x variable increases, so does the y variable.

- Negative Correlation: as the x variable increases, the y variable decreases.

- No Correlation: there is no evident relationship between the two variables; the

dots are scattered around the entire chart area.

Introduction to scatterplots (2)



Right click on a point, choose “Add Trendline” from the drop-down menu.

Excel will draw a line as close as possible to all data points so that there

are as many points above the line as below.

Additionally, you can show the equation for the trendline that mathematically

describes the relationship between the two variables.

Trendline

Introduction to scatterplots (3)



Right click on a point, choose “Add Trendline” from the drop-down menu.

Excel will draw a line as close as possible to all data points so that there

are as many points above the line as below.

Additionally, you can show the equation for the trendline that mathematically

describes the relationship between the two variables.

Trendline

Introduction to scatterplots (4)



Right click on a point, choose “Add Trendline” from the drop-down menu.

Excel will draw a line as close as possible to all data points so that there

are as many points above the line as below.

Additionally, you can show the equation for the trendline that mathematically

describes the relationship between the two variables.

Trendline

Introduction to scatterplots (5)



Introduction to scatterplots (6)

Finally, you can display the R-squared value, R2 (Coefficient of

Determination) on chart, which is used as an indicator of the goodness of fit - It

shows how many points fall on the regression line.

R-squared values range from 0 to 1 - The higher the R-squared, the better

the relationship between two variables is.

Trendline



Introduction to scatterplots (7)

In a scatterplot, each point represents an individual’s data.

We can put labels to the points in order to identify each individual and the

data corresponding to them.



Introduction to Line Charts (1)

Line charts are commonly used to visually represent quantitative data over a

certain time period (i.e. days, months, years).

Typically, independent values such as time intervals are plotted on the

horizontal x-axis, while dependent values such as prices, sales and the like

go to the vertical y-axis.



Introduction to Line Charts (2)

We can draw a multiple line graph, performing the same steps as for

creating a single line graph.

Each data series will be plotted individually.

When creating a multiple line chart, try to limit the number of lines to 3-4

because more lines would make your graph look cluttered and hard to read.



Introduction to Line Charts (3)

By default, the horizontal gridlines are added automatically to help us read

values in line charts.

Actually, we can also manually add drop lines to connect the data points

and their X axis values in the chart.

drop lines



A “trendline” can be also drawn in a time series graph.

In this case, it indicates the general pattern or direction of a time series data

(a specific variable increases or decreases over time).

Introduction to Line Charts (4)

trendline



A “trendline” can be also drawn in a time series graph.

In this case, it indicates the general pattern or direction of a time series data

(a specific variable increases or decreases over time).

Introduction to Line Charts (5)



Highlighting MAX and MIN values (1)

When using column charts to compare values, you may want to highlight the

maximum and minimum values on the chart.

To show the max and min values on a column chart, we will first need to

identify the max and min values of our range - These values will then be used

as a second data series (in a separate column).

Then, we crate the column chart using the different data series.



Highlighting MAX and MIN values (2)

Click on one of the columns in the chart.

Click the “Format Tab” on the Ribbon and the “Format Selection” button.

Enter 100% in the “Series Overlap” field.



Creating a combination chart (1)

Combination charts in Excel let you present and compare two different

data-sets that are related to each other (in a single chart).

With combination charts, you can have two Y-axis, which allows you to have

two different type of data points in the same chart.

A popular example of combination charts is a line & column combο chart.



Creating a combination chart (2)

Select the cells you want to chart, including the column titles and row labels.

From the “Insert Tab”, in the “Charts Group”, click the “Combo” symbol.

Click “Create Custom Combo Chart”.

You may be 

interested in 

plotting the 

annual numbers 

of floods, and at 

the same time, 

also be able to 

show the annual 

number of deaths



Creating a combination chart (3)

Floods

Clustered 

Column

Deaths

Line



Creating a combination chart (4)

Deaths

On the 

Secondary Axis



Creating a combination chart (5)



Creating an interactive chart (1)

There are several ways to make an interactive chart in Excel - You can use

data validation, form controls, slicers, timelines, VBA or hyperlinks.

In the following, we learn how to make an interactive chart with data

validation.



Creating an interactive chart (2)

Step 1: Make a list of all choices

• Select all the product names and go to Namebox (top left corner) and type a

name like “products”.

• Alternatively, you can also list the food names in a separate range and give

that a name (i.e. products).

Step 2: Set up selection mechanism

• Decide which cell will have the user selection (i.e. N8) - Select the cell and go

to Data > Data Validation.

• Select “List” from the “Allow” menu.

• In the “Source” field, enter “=” followed by the named range, i.e. products.



Creating an interactive chart (3)

A “drop-down list” with all the products

Step 3: Find out which product is selected

• For the calculations, we need the number of the product (i.e. what is the

position of the selected product in the “products” list).

• Type the “MATCH” formula in an empty cell, i.e. I2.

• =MATCH(Q5,products,0).

• This will return a number, matching the product user has picked (i.e. Milk =

“1”, Chocolate = “2”, Cheese = “3”, etc.).



Creating an interactive chart (4)

Step 4: Calculating order quantity to show in the chart

• Now, assume we have the number of product selected in cell I2 - Given this,

we can calculate picked product’s quantity (in a new column called

“Picked”) using a simple “INDEX” formula.

• =INDEX(C4:H4,$I$2).

• Now that we have calculated product quantity values for selected product, if

you change I2, you will see values for the relevant product.

Cheese = “3”



Creating an interactive chart (5)

Step 4: Create the chart

• Simply select picked product column and insert a column chart.

• Add axis labels and remove chart title.

• Position the chart under cell N8 (the data validation selection cell).

• Now, when you pick a new product from N8, your chart will update.

The chart when the 

product “Cheese” is 

selected form the drop-

down list



Essential conditional formatting tricks (1)

How to format the entire row

Applying Conditional Formatting to the entire row will be far more

effective in spreadsheets that have many columns.

For example, in the spreadsheet below we’ll format the entire row where the

country in column D is “France”.



How to format the entire row

• Select the entire table of data excluding the header row.

• Click the “Home Tab” on the Ribbon and then the “Conditional

Formatting” button.

• Select “New Rule” from the list.

• Click on “Use a formula to

determine which cells to format”

in the top half of the screen and type

the following formula:

=$D2=“France”.

• Click the “Format” button and

choose the formatting you would like

to apply (i.e. use “Fill color” in order

to make the entire row “yellow”).

• Click ok.

Essential conditional formatting tricks (2)

=$D2=“France”



Essential conditional formatting tricks (3)



Essential conditional formatting tricks (4)

How to use multiple conditions in your Conditional Formatting Rules

To use multiple conditions in “Conditional Formatting” you will need to enter

a formula.

Depending on the logic you want to use this will likely be either the “AND” or

“OR” function.

For example, in the spreadsheet below we’ll format the entire row where the

country is “Brazil” AND the units sold are less than “20”.



Essential conditional formatting tricks (5)

How to use multiple conditions in your Conditional Formatting Rules

• Select the range of cells you want to apply the Conditional Formatting to.

• Click the “Home Tab” on the Ribbon and then the “Conditional

Formatting” button.

• Select “New Rule” from the list.

• Click on “Use a formula to

determine which cells to format”

in the top half of the screen and type

the following formula:

=AND($H2<20,$D2=“Brazil”).

• Click the “Format” button and

choose the formatting you would like

to apply (i.e. use “Fill color” in order

to make the entire row “yellow”).

• Click ok.

=AND($H2<20,$D2=“Brazil”)



Essential conditional formatting tricks (6)



Introduction to Pivot Tables (1)

Excel pivot tables are very useful and powerful feature of MS Excel.

They can be used to summarize, analyze, explore and present your data.

Use Pivot Tables for: a) Summarizing data, b) Listing unique values in any

column of a table, c) Filtering, sorting, drilling-down data without writing one

formula or macro, d) Transposing data, e) Linking data sources outside excel.



Introduction to Pivot Tables (2)

To create a Pivot Table

• Select the range of cells you want to use for the Pivot Table.

• Click the “Insert Tab” on the Ribbon and then the “PivotTable” button.

• Decide whether you want the Pivot Table to appear in a new worksheet or

within an existing worksheet.

Pivot Table

Pivot Table 

Fields



Introduction to Pivot Tables (3)

To specify a Pivot Table

• To specify the data to use in the Pivot Table,

you need move the required fields into the

relevant report areas at the bottom of the field list.

• By simply moving the fields between the different

report areas you change the configuration of the

report, and is why they are known as Pivot Tables.



Introduction to Pivot Tables (4)

- Move the “Product Category” field into

the “ROWS” area.

- Move the “Total Sales Values” field into

the “VALUES” area.

- Move the “Sales Rep” field into the

“ROWS” area (below “Product Category”).



Introduction to Pivot Tables (5)

- Move the “Product Category” field into

the “ROWS” area.

- Move the “Total Sales Values” field into

the “VALUES” area.

- Move the “Sales Rep” field into the

“ROWS” area (above “Product Category”).



Introduction to Pivot Tables (6)

- Move the “Product Category” field into the “COLUMNS” area.

- Move the “Total Sales Values” field into the “VALUES” area.

- Move the “Sales Rep” field into the “ROWS” area.



Introduction to Pivot Tables (7)

- Move the “Product Category” field into the “ROWS” area.

- Move the “Total Sales Values” field into the “VALUES” area.

- Move the “Country” field into the “FILTERS” area.

- Click the filter list arrow and select the required criteria.

- You can add more fields to the “FILTERS” area for more advanced filtering.



To change a Pivot Table calculation

• Click the list arrow on the field being used in the

“Values” area of the Pivot Table and select

“Value Field Settings”.

• Choose the function you wish to use from the list

on the “Summarize Values By” tab.

Introduction to Pivot Tables (8)



Introduction to Pivot Tables (9)

To create a Pivot Chart

• Click the “Pivot Chart” button on the “Analyze Tab” of the Ribbon.

• Select the chart you want to use from the dialog provided.

• The Pivot Chart appears in the

worksheet with the Pivot Table.

• Use the tabs on the Ribbon to

work on your Pivot Chart further.



The VLOOKUP function (1)

The VLOOKUP function is one of the most commonly used and powerful

functions in Excel.

The VLOOKUP function is used for many reasons, ranging from dynamically

linking worksheets, to comparing lists for missing items, to improving and

speeding up data entry.

The Excel VLOOKUP function searches for a value in a list and returns

information from another column, but the same row to that value.

VLOOKUP requires 4 items of information (arguments) to work:

- Lookup value: The value that you are looking for. This value can be a

number, date or text.

- Table array: The table to search for the value in. It looks for the value in the

leftmost column of the table.

- Col index num: This is the column number of the lookup table that contains

the information to return.

- Range lookup: Logical value that could be True or False.



The VLOOKUP function (2)



The VLOOKUP function (3)



The VLOOKUP Function can also be used to lookup a value in a range of

values - To do this, the last argument of VLOOKUP would be set to True, or

omitted.

The following VLOOKUP would do this =VLOOKUP(B2,$E$2:$F$7,2,True).

When performing range lookups it is essential that the first column of the

lookup table is in ascending order - This is not necessary when looking for

specific values and setting the last argument to False.

The VLOOKUP function (4)



Exercise No1

Create a main drop-down list including the options existing in the group

“Category”.

Create dependent drop-down list based on the selection made in the group

“Category”.

Make a selection both from the main drop-down list and the dependent drop-

down lists for all persons included in the spreadsheet taking into consideration

that men don’t like “Books” and women don’t like “Games” and “Sports”.



Exercise No2

Create a scatterplot of Cl-EC values.

Draw a trendline in the scatterplot, and display the trendline's equation and the

R-squared value (R2).

Evaluate the relationship between the two variables based on the trendline

form and the R-squared value.



Exercise No3

Create a multiple line chart including the data related to all three cities.

Draw a trendline and display the trendline's equation for each case.

Create a combination chart using data from column “All Stds” (column chart)

and column “Civil Engineering Dpt” (line chart).



Exercise No4

Use Conditional Formatting to highlight the entire row where the product

category in column F is “Seafood”.

Use Conditional Formatting to highlight the entire row where the product

category in column F is “Seafood” and the country in column D is “France”.

Use Conditional Formatting to highlight the entire row where the product

category in column F is “Beverages” and the units sold are greater than 20.



“Developing Excel skills is a powerful way to

start analyzing data like the professionals do”


